XenApp Server Is Not Listening On Port 1494 Preventing Connections

XenApp Server Is Not Listening On Port 1494 Preventing Connections

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Article ID: CTX204057

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Updated On:

Description

Server will randomly stop accepting connections. netstat -a it does not show the XenApp server listening on port 1494. It is still possible to use Microsoft's RDP to connect to the server.
and the ica-tcp port is not disabled.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

There are two solutions.

Solution 1

Complete the following steps to resolve the issue:

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

  1. Run Regedit.

  2. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services.

  3. Create a key named WDICA.

  4. Manually add the following values:
    ErrorControl: REG_DWORD : 0
    Start: REG_DWORD : 0x3
    Type: REG_DWORD : 0x1

  5. Reboot the server.

  6. After the reboot, a subkey named Enum will be created with the following values:
    0 : REG_SZ : Root\LEGACY_WDICA\0000
    Count : REG_DWORD : 0x1
    NextInstance : REG_DWORD : 0x1

  7. Make a Custom ICA Connection to the server IP address. The connection should now connect successfully.

    Complete the following steps if the preceding resolution does not resolve the issue:

    1. Check if HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\LEGACY_WDICA and its subkeys exist.

    2. Add permissions to the key in order to save and restore the key from a working server. When this key is manually deleted and the server is rebooted, the key should regenerate automatically.

    3. If the key does not automatically regenerate, restore a copy of this key from a known good server or manually create the entries. When replacing this key with a copy of the key from another server, navigate to the following location:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\LEGACY_WDICA\0000\Control

    4. Delete the data of the following value located within the key referenced in step 1 and reboot the server:
      "DeviceReference"=dword:8188fd10

    5. Data should repopulate after the reboot.

      Note: The cause for the disappearance or corruption of these registry keys is currently unknown. Reboot the XenApp server after making the preceding registry changes. 

      Solution 2

      Because Windows 2008 removing and re-adding the ica-tcp port creates problems due to a Microsoft change to sfi the port is not listening we would need to repair the install of XenApp to repair the ica-tcp port that is not working as follows:

      Add/Remove programs > Change > repair > XenApp 6.5.

       

      Problem Cause

      This issue is caused by a corrupt or faulty ica-tcp port.

       

      Issue/Introduction

      XenApp Server Is Not Listening On Port 1494 Preventing Connections.

      Additional Information

      A program installed on the XenApp server is trying to listen on 1494 can also stop as from using it. Ensure that any network scanners or other programs are not interfering with that port.