VDI Session Launches Then Disappears

VDI Session Launches Then Disappears

book

Article ID: CTX203760

calendar_today

Updated On:

Description

The VDI session disappears during desktop launch process.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

If a virtual machine containing a desktop VDA closes before the logon process completes, you can allocate more time to the process. The default for 7.6 and later versions is 180 seconds (the default for 7.0-7.5 is 90 seconds).

On the machine (or the master image used in a Machine Catalog), set the following registry key:

Key: HKLM\SOFTWARE\Citrix\PortICA
Value: AutoLogonTimeout
Type: DWORD
Specify a decimal time in seconds, in the range 0-3599.

If you change a master image, update the catalog.

Note: This setting applies only to VMs with desktop (workstation) VDAs; Microsoft controls the logon timeout on machines with server VDAs.


Problem Cause

The issue was a result of the file server storing the user profile.

Issue/Introduction

The VDI session disappears during desktop launch process.