Unable To Reconnect To A Disconnected Session When Using CLI Command "selfservice.exe -ipoll"

Unable To Reconnect To A Disconnected Session When Using CLI Command "selfservice.exe -ipoll"

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Article ID: CTX203683

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Updated On:

Description

When using Citrix Receiver 4.3 on a Windows 7 workstation, users want to disconnect and reconnect their apps via CMD prompt.
After disconnecting from an active session using the CLI command: "selfservice.exe - disconnectapps" (which works fine)
Domain Users are unable to reconnect to a disconnected session when using CLI command "selfservice.exe -ipoll command.
A local user account (not a domain user account) doesn't have the issue.
 

Resolution

1. Changed Provider Order on the end point device (Windows 7).
2. Used PNAgent URL by adding the suffix "config.xml" instead of using the "discovery" suffix; 

Note
: When using the selfservice.exe Command with the -ipoll switch Session re-connection worked after the 2 changes above .

User-added image
 

Problem Cause

Provider Order in the client device did not have the Single Sign On on the top of the list.
The PNAgent URL did not match the PNAgent url listed in the StoreFront Console.

Issue/Introduction

Unable To Reconnect To A Disconnected Session When Using CLI Command "selfservice.exe -ipoll". When using Citrix Receiver 4.3 on a Windows 7 workstation, users want to disconnect and reconnect their apps via CMD prompt.

Additional Information

Driving the Citrix Receiver Self-Service Plug-in Programmatically - http://support.citrix.com/article/CTX200337
How to Configure Citrix Receiver Pass-Through Authentication for StoreFront or Web Interface - http://support.citrix.com/article/CTX200157