APNs Communication Fails

APNs Communication Fails

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Article ID: CTX203343

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Updated On:

Description

Device APNS communication fails.

The following error is reported:
INFO com.sparus.nps.ios.push.ApnsHandler - Not using APNS connection pool
WARN com.sparus.nps.ios.push.ApnsHandler - Sending message to APNS failed

Resolution

Complete the following steps to fix this issue:
 

1. XenMobile need port 443 or 2197 to communicate with *.push.apple.com. Apple devices also need port 5223 to communicate APNs.

2. Check if the IP range 17.0.0.0./8 is opened by firewall admin. If the IP range is not allowed, allow the IP range.

3. Ensure if a proxy has been added to the XenMobile Server that the applicable exclusions have been added for APNS traffic

4. Regenerate (RENEW) the APNs Certificate if already installed.


Problem Cause

The APNs servers use load balancing. Devices will not always connect to the same public IP address for notifications.The entire 17.0.0.0/8 address block is assigned to Apple. Therefore, it is best practice to allow this range in the firewall settings.

Issue/Introduction

Device APNs communication fails.

Additional Information

If you‘re not getting Apple push notifications
https://support.apple.com/en-us/HT203609