Citrix Receiver Error: "Check network connections" When iPad Goes into Sleep Mode

Citrix Receiver Error: "Check network connections" When iPad Goes into Sleep Mode

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Article ID: CTX203257

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Updated On:

Description

This article is intended for Citrix administrators and technical teams only.

Non-admin users must contact their company’s Help Desk/IT support team and can refer to CTX297149 for more information.

After unlocking the iPad the Citrix Receiver Shows the following message: Connection not possible. Check the network and try again.

Resolution

To resolve this issue:
  1. In the Receiver app, go to Settings > Advanced > Caffeine.
  2. Activate "Stay Awake".
This will prevent the device from going to sleep/locking when there is a session active in Receiver.

Problem Cause

When an iOS device is locked or goes to sleep, Apple intentionally disconnects the network connection in what appears to be a power saving feature. The Citrix session will then become disconnected when the device stays locked/asleep over 5 minutes.

Issue/Introduction

After unlocking the iPad the Citrix Receiver Shows the following message: Connection not possible. Check the network and try again.