Cannot change the IP address of the XenMobile server on VMware

Cannot change the IP address of the XenMobile server on VMware

book

Article ID: CTX202982

calendar_today

Updated On:

Description

Cannot change the IP address of the XenMobile server on VMWare.

This mostly arises in the following scenario.  Customer clones a XenMobile Server for a cluster, then changes the IP address of the clone in the CLI, reboots the cloned XenMobile Server and the IP reverts back to the IP of the original cloned XenMobile Server (IP change does not take effect).

Resolution

Citrix recommends the following:

Solution 1:
  1. Shutdown the cloned XenMobile Server.
  2. Disable the OVF Environment Transport from VMWare Tools
Disable the OVF Environment Transport from VMWare Tools:
  1. Start the VM, change the IP in the CLI, reboot and the IP change should take effect

Solution 2:
  1. While the VM is turned on, have an admin with rights edit the OVF IP settings.
Edit the OVF IP setting if they have rights and the system is shutdown.


​Solution 3:
  • Turned off VM.
  • Log into vSphere Client VM server properties.
  • Navigated to Options > vApp Options > Properties > Networking Properties.
  • Manually configure new network settings.
  • Start VM.

​There are other potential solutions.  Please contact VMware for other solutions or if you still see the issue.

Problem Cause

vApp Options are configured in the environment and the vApp Network properties are taking precedence over the XenMobile network configuration script.  The information is stored in the OVF environment and you can view this information when the VM is powered on.  This config information is retained on a new VM and on cloned VMs.  

Issue/Introduction

Cannot-change-the-IP-address-of-the-XenMobile-server-on-VMware.

Additional Information

Working with Networks in a vApp
http://pubs.vmware.com/vcd-80/index.jsp#com.vmware.vcloud.users.doc_80/GUID-FCBC791B-3183-4CD9-A194-856E98CC32D3.html