Slow App Enumeration in StoreFront 3.0 with Receiver 4.3
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Article ID: CTX202469
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Updated On:
Description
This article is intended for Citrix administrators and technical teams only.Non-admin users must contact their company’s Help Desk/IT support team and can refer to CTX297149 for more information
App enumeration takes up to 4 mins. You can expedite the app enumeration by restarting the self service services.
Resolution
Slow app enumeration. [#492154] There are two workarounds for this:
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If the user has enabled RemoveappsOnLogoff and RemoveAppsonExit, and is experiencing delays in app enumeration at every logon, then the following workaround configuration should reduce the delay.
HKCU has preference over HKLM.
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Reg add HKCU\Software\Citrix\Dazzle /v ReuseStubs /t REG_SZ /d "true"
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Reg add HKLM\Software\Citrix\Dazzle /v ReuseStubs /t REG_SZ /d "true"
- Allow a machine to use pre-created stub executables that are stored on a network share:
- On a machine, create stub executables for all of the apps. The easiest way to do this is to add all the applications to the machine via Windows Receiver, and it will generate the executables.
- Harvest the stub executables from %APPDATA%\Citrix\SelfService. You only need the .exe files.
- Copy the executables to a network share. For example \\ShareOne\ReceiverStubs
- Now for each client machine that is to be locked down, set the following registry keys
- Reg add HKLM\Software\Citrix\Dazzle /v CommonStubDirectory /t REG_SZ /d "\\ShareOne\ReceiverStubs"
- Reg add HKLM\Software\Citrix\Dazzle /v CopyStubsFromCommonStubDirectory /t REG_SZ /d "true"
It is also possible to set these on HKCU if you prefer. HKCU has preference over HKLM.
- Exit and Restart Receiver to test.
Note: HKLM paths are HKLM\Software\Citrix\Dazzle on 32-bit. HKLM paths are HKLM\Software\Wow6432Node\Citrix\Dazzle on 64-bit machines.
Problem Cause
This is a known issue.
Issue/Introduction
App enumeration takes up to 4 mins. You can expedite the app enum by restarting the self service services
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