COM Port Communication Issues when 20 or More Users are Concurrently Using COM Ports in XenApp 6.5
book
Article ID: CTX202448
calendar_today
Updated On:
Description
When you configure COM port redirection for users on a XenApp 6.5 environment, COM port communication might fail for several users during peak times, when you have 20 or more users concurrently using the COM ports.
You can still map COM ports using "net use", but communication for the actual devices in use on the endpoints fail.
On the Event Logs, you see the following error:
Event ID: 54
Source: PICASER
Description: Empty
Environment
Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.
Resolution
This is due to a default setting that limits concurrent worker threads in PICASER.SYS to 20. There is a registry setting with which this limit can be increased.
The setting is found at: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\picaser\Parameters DWORD "MaxThreads".
Set it to 300 (decimal) and reboot the server.
Problem Cause
Default max number of PICASER.SYS worker threads.
Was this article helpful?
thumb_up
Yes
thumb_down
No