Intermittent Connection Failures/Black Screen Issues When Connecting from Multi-Monitor Client Machines to Windows 7 VDA with VDA 7.x on vSphere/ESXi

Intermittent Connection Failures/Black Screen Issues When Connecting from Multi-Monitor Client Machines to Windows 7 VDA with VDA 7.x on vSphere/ESXi

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Article ID: CTX201804

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Updated On:

Description

When connecting from a client machine with multiple monitors to a Windows 7 VDA 7.x machine hosted on a VMware hypervisor, users might see one of the following behaviors:

  • Intermittent connectivity issues resulting in connection failure messages.

  • A black screen and the session just stays with this black screen and no errors.

  • Citrix Director might log these failures as “Connection Timeout”.

Note: This also affects Windows Server 2008 R2.

Resolution

The following workarounds have been identified to resolve the problem. Note that some workarounds might not resolve the problem in certain setups. Try them one by one to find out the suitable one that works in your environment.

Workaround 1

Remove the VMware video driver from the affected VM using the following sequence:

  1. Remove the VDA and VMware Tools from Add Remove Programs.

  2. When installing VMware Tools, select Custom install and unselect the SVGA Driver.

  3. Reboot the machine after VMware Tools installation is complete.

  4. Open Device Manager and under Display adapters ensure that you see Standard VGA Graphics Adapter.

  5. Install XenDesktop 7.x VDA using the ISO and reboot the machine.

  6. Ensure that in Device Manager you see only the Standard VGA Adapter (including the Warning) and Citrix Drivers (Citrix Display Driver [Citrix Systems - WDDM], Citrix Display Mirror Driver [Citrix Systems Inc. Display Mirror Driver]).

  7. Test ICA connection.

If Windows 7 was correctly identifying the primary adapter then the SVGA adapter would not be in use anyway.

Note: Disabling or removing the SVGA adapter might lead to a degradation in console performance which should not be something you would use very often as it would usually only affect updating the base image.  

Workaround 2

Recreate the Windows persistent database that stores the Display configuration:

  1. Back up the following registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers

  2. Delete the following registry keys:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Connectivity

  3. Reboot the VDA and test ICA connection.

Workaround 3

Upgrade the VDA OS to Windows 8.1.

Workaround 4
Enable Legacy Graphics Mode, Visual Quality - Always Lossless and Always Allow Lossless compression.


Problem Cause

This is a known issue on Windows 7 which has been resolved in later Microsoft operating systems Win 8.x and up. Windows 7 can sometimes get confused and change what is seen as the primary adapter.

We recommend customers contact Microsoft support if the workarounds do not work or are impractical for your setup. We are actively investigating ways to programmatically workaround the issue with Microsoft Windows 7.

Issue/Introduction

Intermittent Connection Failures/Black Screen Issues when Connecting from Multi-monitor Client Machines to Windows 7 VDA with VDA 7.x on vSphere/ESXi.

Additional Information

Microsoft is no longer investigating this issue as the workarounds have been successful and Windows 7 is out of support. If one of the above workarounds resolve the problem for you and if you need further assistance regarding the issue, you can open a case with Microsoft support.

CTX139375 - Blank Screen During Log On or Log Off Server OS Machines.