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Article ID: CTX201117
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Updated On:
Description
When attempting to open an attachment in Secure Mail which is greater than 'x' MB, it fails to open. The following error appears:
- "Sorry. There was a problem downloading this file"
Example:
- Attachment 10MB or greater fails to open
- However, attachment with 9 MB or smaller size opens without any issue
Resolution
On the CAS servers, the value of "httpRuntime maxRequestLength" has to be increased in the web.config file.
Change the parameter
<httpRuntime maxRequestLength=”10240″/> to a higher value.
This can also be checked via IIS:
On Exchange you can run a PowerShell command to see the current policy and make the necessary changes:
- Get-MobileDeviceMailboxPolicy -Identity <PolicyName>
- Check the MaxAttachmentSize value
- Set-MobileDeviceMailboxPolicy -Identity <PolicyName> -Maxattachmentsize:Unlimited
- Set size to your preference
Double checked the setting was changed
Get-MobileDeviceMailboxPolicy -Identity <PolicyName>
Additional resources below as instructions may vary per Microsoft Exchange version:
Problem Cause
This issue occurs because of the CAS server settings configured on your machine. Exchange is throwing error code 11 which translates to "The requested data size is too large".
Refer to the Microsoft article: 2.2.3.162.7 Status (ItemOperations).
Issue/Introduction
When attempting to open a PDF attachment in Secure Mail that is greater than 10 Megs, it fails to open up and you get an error "Sorry. There was a problem downloading this file". Anything 9 Megs or smaller opens up without issue.