Error: “No response received for successful send. Error number 0xA0070002”

Error: “No response received for successful send. Error number 0xA0070002”

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Article ID: CTX201063

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Updated On:

Description

In environments where large amount of vDisk are being managed in a single physical location for vDisk stores shared by multiple Sites, or in a environment where there are large number of vDisk that are not imported in the vDisk store, but they are kept in physical vDisk store, attempt to import a vDisk may return the mentioned error: “Warning Process Communication: No response received for successful send. Error number 0xA0070002”.
PVS error

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

To resolve the issue we need to increase the timeout that will be used to read vDisk (.vhd) files. We can accomplish the same following registry

Key Name : HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\ProvisioningServices\Manager
Name: ServerReplyTimeoutMilliseconds
Type: REG_DWORD
Data: Set the decimal value to more than 10,000 ms (10 seconds, which is default value) but less than 29,000 ms (29 seconds)
 
Note: Do not configure the registry value more than 29,000 ms (29 seconds). Different Provisioning Server timeout is triggered at 30,000 ms (30 seconds).

Problem Cause

The issue is happening because Provisioning Services Console is timing out in attempt to read all available vDisk (.vhd) files for import.

Issue/Introduction

This article describes how to manually configure a Provisioning Server importing vDisk issue in environments where the following error is received in the Provisioning Services Console: “Warning Process Communication: No response received for successful send. Error number 0xA0070002”.