Citrix Studio unable to connect to Citrix License Server with Error ID: XDDS:9509EEA3

Citrix Studio unable to connect to Citrix License Server with Error ID: XDDS:9509EEA3

book

Article ID: CTX200937

calendar_today

Updated On:

Description

Citrix Studio console is reporting it is unable to find a Citrix License Server with the following error code:

Error ID: XDDS:9509EEA3
Exception: System.ArgumentNullException Value cannot be null.
Parameter name: certificate

User-added image

Resolution

The Citrix Web Services for Licensing windows service needs to be started on the Citrix License server.

NOTE: Studio, Director, and the Licensing Administration PowerShell Snap-in use Citrix Web Services for Licensing to communicate with the License Server and manage users, allocate and install licenses, display License Server health, license usage, and other alert messages. The Simple License Service also uses it.

Citrix Documentation:
Licensing overview

Problem Cause

The Citrix Web Services for Licensing windows service is not running or listening on port 8083.