LDAP Communication Error on XenMobile Device Manager

LDAP Communication Error on XenMobile Device Manager

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Article ID: CTX200823

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Updated On:

Description

The following LDAP communication error appears on XenMobile Device Manager:

javax.naming.CommunicationException: simple bind failed: xxxx-xxx-xxx.xxx.xxx.com:666
[Root exception is javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: 

Unable to authenticate and users or deploy any MDM packages. 

MDM Logs
2014-05-01 11:40:31,785 [http-nio-443-exec-147]  INFO com.sparus.nps.ios.push.MdmServlet  - MDM service currently unavailable com.sparus.nps.push.UnavailableException: Cannot refresh user data: test@xxxx.com at com.sparus.nps.ios.security.AuthUtils.forceRefreshUserData(AuthUtils.java:66) at com.sparus.nps.ios.security.ZdmCertAuthenticationDelegate.authenticate(ZdmCertAuthenticationDelegate.java:211) at com.sparus.nps.ios.security.MdmAuthenticator.authenticateKnownCert(MdmAuthenticator.java:272)
Caused by: javax.naming.CommunicationException: simple bind failed: xxxx-xxx-xxx.xxx.xxx.com:666 [Root exception is javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed:

Resolution

Complete the following steps to fix the issue:

  1. Renew the internal LDAP certificate.

  2. Re-import certificate into the LDAP's Wizard.


Problem Cause

The error is a generic Java failure when the certificate used for negotiating the SSL connection is invalid. 

Issue/Introduction

LDAPS Communication Error on XenMobile Device Manager