Error: "There are no apps or desktops assigned to you at this time" after Logging into StoreFront

Error: "There are no apps or desktops assigned to you at this time" after Logging into StoreFront

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Article ID: CTX200583

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Updated On:

Description

After logging in to StoreFront, user receives the message "There are no apps or desktops assigned to you at this time."

The StoreFront events shows "Event ID 4003".

Resolution

Complete one of the following procedures to fix the issue:

  1. Upgrade to StoreFront 2.6.

  2. Change the server bypass behaviour as mentioned in the eDocs - Configure server bypass behavior.

OR
  1. Either use HTTP (Port 80) or you can setup the controller to use HTTPS as mentioned in the eDocs - Use SSL on Controllers and change HTTP/HTTPS ports.

  2. To change the port in which StoreFront and the XD controller communicate:

    Open StoreFront console > Stores > Manage Delivery Controllers (on the Actions Pane), click on the controller and then Edit.

    Note: This is only the communication between StoreFront and the XD controller, if you have setup a SSL certificate and you are using HTTPS to access StoreFront URL, the communication between StoreFront and the End user device will still with be secure.

    User-added image

Problem Cause

This issue can occur during the following scenarios:

  • The user is not assigned to any delivery group.
    Check by opening Desktop Studio > Delivery Groups > Edit Delivery Group > Users and verify that the user that is launching the application is assigned to that Desktop or Application.
  • StoreFront is setup to communicate using HTTPS (Port 443) with the Delivery Controller and the controller was not setup for HTTPs.
  • A socket was closed on StoreFront server, preventing the user to contact the XML brokers and causing a timeout when enumerating the resources.

Issue/Introduction

This article provides solution to the error "There are no apps or desktops assigned to you at this time" on StoreFront.

Additional Information

CTX141317 - NetScaler Gateway 10.5, Maintenance Release 54.9
Known Issue: When you use the Set Up NetScaler for XenApp/XenDesktop wizard in NetScaler, apply optimization settings, and bind the cache policy globally, when users log on with the NetScaler Gateway Plug-in and open Citrix Receiver, the applications and desktops do not appear. The following message appears: There are no apps or desktops assigned to you at this time. Citrix recommends disabling the optimization settings.

[From NG_10_5_53_9][#411152]