Error: "Cannot Access the Store" When Accessing StoreFront Through NetScaler Gateway

Error: "Cannot Access the Store" When Accessing StoreFront Through NetScaler Gateway

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Article ID: CTX200582

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Updated On:

Description

Access to applications work internally however externally accessing the applications through NetScaler Gateway displays the following error:
Cannot Access the Store

Resolution

Complete the following steps to resolve the issue:

  1. Change the PL_OS session policy from REQ.HTTP.HEADER USER-AGENT CONTAINS CITRIX RECEIVER || REQ.HTTP.HEADER REFERRER NOTEXISTS to REQ.HTTP.HEADER USER-AGENT CONTAINS CITRIX RECEIVER && REQ.HTTP.HEADER X-CITRIX-GATEWAY EXISTS and set priority to 100.

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  2. Remove SETVPNPARAMS_POL which comes from using the wizard.

  3. Change PL_WB from nstrue to REQ.HTTP.HEADER USER-AGENT NOTCONTAINS CITRIXRECEIVER and set priority to 110.

  4. Bind STA from StoreFront to NetScaler Gateway vserver.

  5. NetScaler Gateway vserver is set to smart access mode and max users are set to 10 but the appliance is only licensed to support 5 users. Change the license from smart access mode to basic mode.

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Problem Cause

The following are the causes for this issue:

  • Session policies are set incorrectly on the NetScaler Gateway virtual server.

  • NetScaler Gateway virtual server does not have STA from StoreFront bound.

  • NetScaler Gateway virtual server is set to smart access mode while it is licensed for basic mode.

Issue/Introduction

Error: "Cannot Access the Store" when accessing StoreFront through NetScaler Gateway.