Applications are Not Enumerating for Users when Logging on to StoreFront

Applications are Not Enumerating for Users when Logging on to StoreFront

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Article ID: CTX200540

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Updated On:

Description

When the user logs on to StoreFront, applications are not appearing for the user to launch. No error messages are displayed.

When you check the users account in XenApp, the user account has applications configured for it.

Resolution

Complete the following steps:

  1. Validate if the XML port being used by the XenApp server is not blocked by a firewall between the XenApp server and the StoreFront server which is the usual cause.

  2. The servers that you have listed in your StoreFront Store as Delivery Controllers and they are the servers that are running the XML (XenApp) and Broker Service (XenDesktop).

  3. For Instructions on how to check which servers are used as your StoreFront Delivery Controllers, see Citrix documentation - To add XenDesktop, XenApp, and VDI-in-a-Box resources to the store.

  4. You can perform a telnet test form the StoreFront server to the XenApp server as your Delivery Controller in StoreFront also long as the Telnet Client Windows feature which is installed on both server. (this is not installed by default in Windows 2008 R2 and later)

  5. Telnet Client Windows feature would need to be added to the Storefront server and the XenApp server you have specified in StoreFront as a Deliver Controller. To enable it, go to Windows Server ManagerFeatures node > Add features wizard and add the Telnet Client.

    telnet

  6. From the StoreFront servers command prompt, run:
    telnet X.X.X.X 80

    where X.X.X.X is the ip address of the XenApp server (10.20.30.40 for example) and 80 represents the XML port used on the XenApp server, 80 is the default port for XML if you are using a different port for example 8080 you would use that.

  7. You are looking for it to accept the command (clear the command prompt window with a dash at the top letting you know it was able to connect).

  8. if you get the message "Connecting to X.X.X.X...Could not open connection to the host, on port 80: Connect failed" then the port is closed between the two servers which is because of a firewall.

  9. Adjust your firewall settings to allow the XML traffic between the XenApp server and the StoreFront server and that will resolve your issue with applications not enumerating for users.

Notes

Perform the following steps to verify if the preceding steps resolve the issue:
  1. The user account has applications assigned to it in XenApp or the user will login without error and see no applications.

  2. The XML service is running on the XenApp server configured as a Delivery Controller in StoreFront.

  3. StoreFront has the correct XenApp server listed as a Delivery Controller with the correct XML port being used by the XenApp server.

 

Problem Cause

 A firewall was blocking the XML port between the XenApp server and the StoreFront server.

 

Issue/Introduction

Goes over the typical cause and solution for applications not enumerating for users when they log into a StoreFront Server.