Blue Screen with Error Code 0x0000007B When Booting a Target from a vDisk Using Target Device Software 6.x or 7.x

Blue Screen with Error Code 0x0000007B When Booting a Target from a vDisk Using Target Device Software 6.x or 7.x

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Article ID: CTX200405

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Updated On:

Description

When booting a Target from a vDisk using Target Device Software 6.x or 7.x, you might get a Blue Screen with error code 0x0000007B and the following error description: “ERROR: SOCKET…”

The error description will contain additional values as shown in the following screen shot:
User-added image

Resolution

To resolve the issue, upgrade the environment to PVS 7.6.

In PVS 7.6, the Windows 2008 R2/Windows 7 and 8 target devices use a new driver. The new driver supports re-initialization, and therefore the solution is that the BNIStack driver will register with Winsock on the second registration, when the NIC miniport is ready at a later callback time. 

In previous versions of PVS, the Windows 2008 R2/Windows 7 target devices still use the old driver which does not support re-initialization, so the fix cannot be ported to previous versions of PVS.

Problem Cause

This error can be caused by some modern Network Card Drivers which have a lengthy initialization cycle. This causes the NIC miniport instance to not be ready when initializing the BNIStack driver.

Issue/Introduction

This article provides resolution to the blue screen error code 0x0000007B