Published Applications or Desktops Do not Launch or Disappear during Launch

Published Applications or Desktops Do not Launch or Disappear during Launch

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Article ID: CTX200393

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Updated On:

Description

Published Applications or Desktops don’t launch, or disappear during launch. There are no errors presented to the user, and nothing in the Event Log of the XenApp server or VDA hosting the application.

The issue can present 2 different symptoms:

  • The application appears to launch then immediately closes.
  • The user sees application starting notifications, and after that, the application is never actually launched.

Resolution

WARNING! Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

 

Cause 1 - LogoffCheckSysModules registry value incorrectly configured

  1. On the XenApp Server VDA, check the registry for the following key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Citrix\wfshell\TWI

Name: LogoffCheckSysModules
Type: REG_SZ
Value : (Applications executable name. For example, MYAPP.exe)

  1. If the LogoffCheckSysModules registry value exists, then make sure that it does not contain the executable for the application that the user is trying to launch. If the executable is present in this registry value, remove the executable name from this registry value.
  •  This registry value is meant to close out secondary or child processes that a main application will launch but not close upon exit. Putting the main executable for an application under this key can cause it to close out the application before it launches.
  1. Microsoft Remote Desktop Session Host has a similar registry configuration for the same purpose. Make sure the application executable is not included as a value under this key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\Sysprocs

Name: (Application’s executable name. For example, MYAPP.exe)
Type: REG_DWORD
Data: 0

 

Note: If a key exists with the executable name of the application having launch issues, backup the registry key, and then delete it.



 

Cause 2 – Application not launching in a timely manner

  1. There are a couple registry values that can be tweaked to give the application more time to launch. For example, if you are publishing Explorer, then Explorer will not launch unless LogoffCheckerStartupDelayInSeconds is set to 10 seconds (hexadecimal) or higher.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Citrix\wfshell\TWI
Name: LogoffCheckerStartupDelayInSeconds
Type: REG_DWORD
Data (Decimal): An integer for the length of time to wait for application start. - Enter the delay time in seconds, up to 10 minutes (600 seconds)>

 

Note:

  • The registry setting written above doesn't work anymore in CVAD7.15 and later.
  • You need to configure via Policy [Logoff Checker Startup Delay] in CVAD7.15 and later.
  • Start with 10 seconds and move up from there 10 seconds at a time if needed.
  • Doubled value is used for wait time. For example, if 10 seconds are set, the wait time is 20 (10 x 2) seconds.

 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Citrix\wfshell\TWI
Name: ApplicationLaunchWaitTimeoutMS
Type: REG_DWORD
Data (Decimal): <desired additional time-out, in milliseconds >


Note: Start with 100000 milliseconds and move up from there to 300000 milliseconds if needed.

Note:
This value is also available as a Policy setting. Any value set via policy will override the value set in the registry of the VDA.
 
Studio 
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Citrix Cloud 

 

  1. Desktop VDAs have an additional registry value that can be tweaked. If a desktop VDA closes before the logon process completes, you can allocate more time to the process. The default for 7.6 and later versions is 180 seconds (the default for 7.0-7.5 is 90 seconds). On the VDA machine (or the master image used in a Machine Catalog), set the following registry value:

 

HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\PortICA
Name: AutoLogonTimeout
Type: REG_DWORD
Data (Decimal): <specify a decimal time in seconds, in the range 0 to 3600>

Note: This setting applies only to VMs with desktop (workstation) VDAs; Microsoft controls the logon timeout on machines with server VDAs.


Problem Cause

  1. LogOffCheckSysModules or SysProc registry keys have been incorrectly configured
  2. The affected published application needs more time to complete its initialization and launch.

Additional Information

CTX891671 - Graceful Logoff from a Published Application Renders the Session in Active State
CTX138404 - Application Connection Starts but disappears after timeout
CTX128009 - Explorer.exe fails to launch
Microsoft Technet - Remote Desktop or RemoteApp does not terminate due to spawned splwow64.exe