Citrix Director Licensing Status shows "Cannot Retrieve the Data"

Citrix Director Licensing Status shows "Cannot Retrieve the Data"

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Article ID: CTX200309

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Updated On:

Description

Citrix Director Licensing Status Panel shows “Cannot Retrieve the Data” when upgraded to Citrix Director 7.6 from earlier versions.
User-added image

-On Director server getting following errors on the event viewer:

Failed to connect to the data source  'Unknown error'
Verify that the data source is available 

User: 'Domain\user'
Console operation: 'Retrieving license server alerts data…'

Additional diagnostic information (error message):
'The server committed a protocol violation. Section=ResponseStatusLine'

Resolution

Resolution 1

Open the Command Prompt or PowerShell and run the following:

C:\inetpub\wwwroot\Director\Tools\DirectorConfig.exe /upgrade


Resolution 2

  1. Edit the Web.config file from location C:\inetpub\wwwroot\DesktopDirector 
  2. locate Bindings "SLSUnauthServiceBinding" and "WSLUnauthServiceBinding" in <customBinding>-Section
  3. Under both the sections, replace keepAliveEnabled="true" with keepAliveEnabled="false"
  4. Restart IIS.

Problem Cause

The XenDesktop Meta Installer is not using the switch/upgrade while upgrading Citrix Director as a result web.config of Director does not get updated with the required settings for a valid Licensing Status.

Note: This issue occurs only when Citrix Director is upgraded with other components of XenDesktop and not when only Citrix Director option is selected for upgrade in Meta Installer.