Vendor Daemon down on License Administration Console

Vendor Daemon down on License Administration Console

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Article ID: CTX200151

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Description

Vendor Daemon Down

Licensing Service Crashes

License Administration Console error "Vendor Daemon down: CITRIX" and "No such product or vendor exists: CITRIX" displays. 

Resolution

Before attempting any instructions, create a back up of the current configuration. 
  • Note: The Citrix License Administration Console has reached End of Life (EOL) and End of Support (EOS) in Citrix Licensing 11.16.3. Use the Citrix Licensing Manager.
 
  1. Go to the Administration link, select Vendor Daemon Configuration tab and attempt to start the Vendor Daemon service. If this fails, proceed to step 2.
  2. Delete activation.xml and concurrent.xml files from the license server.

Default Path:
  • C:\ProgramFiles\Citrix\Licensing\ls\conf\activation_state.xml and concurrent_state.xml on a 32-bit server
  • C:\ProgramFiles(x86)\Citrix\Licensing\ls\conf\activation_state.xml and concurrent_state.xml on a 64-bit server
  1. Open services.msc and Stop and start Citrix Licensing Service. If this fails, proceed to step 4.
  2. Remove all license files except the citrix_startup.lic and CITRIX.opt file from MyFiles directory and restart the citrix licensing service and Check if the Vendor Daemon is up. If this fails, proceed to step 5.
  3. Select Citrix Licensing Service, right click and select properties and change the startup type to Automatic (Delayed Start). 
  4. Change the Maximum Number of license server Manager receiving threads from 0 to 10 and save.
  5. Re-install the License Administration Console by deleting the Licensing folder permanently from C:\Program Files\Citrix (Keep backup of any product license files which are required).
  6. Upload the necessary license files after Re-installation
If no technical support agreement exists, contact Citrix Support Sales for support options. 

Problem Cause

Invalid/corrupt license or .opt files under Myfiles folder or corrupt .xml files under the conf folder.

Issue/Introduction

This article provides several different resolutions attempting to resolve the issue of the Vendor Daemon not working properly