Unable to Remove Decommissioned Server from StoreFront

Unable to Remove Decommissioned Server from StoreFront

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Article ID: CTX200085

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Updated On:

Description

Unable to remove decommissioned server from StoreFront deployment using StoreFront GUI and Remove Server action.
The console is stuck and the following error appears:
“Cannot Remove Server”

In this case, in the StoreFront console you might see the following warning message:

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In addition, the following Synchronization Status error message might appear:

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Resolution

Complete the following steps to fix the issue:
  1. Close the StoreFront consoles on all servers (if open).

  2. Locate C:\Program Files\Citrix\Receiver StoreFront\ClusterManagement\feature.config file.

  3. Remove the server that you no longer want in the group by deleting the member entry.
    For example, remove <member hostname="mybadserver" servername="mybadserver" certificateThumbprint="D1DAD2572FE843F8C2BB544C59222DDA6EF7E1EB" />.

  4. Locate C:\Program Files\Citrix\Receiver StoreFront\Services\PeerNameResolution\Citrix.DeliveryServices.ServiceHosting.WindowsServiceHost.exe.config.

  5. Search for the clients section: <clients authenticationMode="windows" portSharingEnabled="true">.

  6. Remove the server that should no longer exist in the group by deleting the “add” entry.
    For example, remove <add name="mybadserver" uri="net.tcp://mybadserver/Citrix/PeerResolverService/Replication" />.

  7. Restart the Citrix Peer Resolution Service.

  8. Remove the server from the local Windows group CitrixClusterMembers.


Problem Cause

The working StoreFront server is trying to communicate with the decommissioned server and is not getting the expected responses; therefore cannot remove the server from the Server Group.

Issue/Introduction

Unable to remove decommissioned server from StoreFront.