AAA Login through NetScaler Fails with Error: “Internal server error 31”
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Article ID: CTX200038
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Updated On:
Description
AAA login through NetScaler fails with error "internal server error 31". This issue is observed whenever a site is accessed with a long URL.
Resolution
Workaround
Clear the authnProfile setting on Load Balancing virtual server and configure authenticationHost on the same Load Balancing virtual server. Here, authenticationHost must be an FQDN (Fully Qualified Domain Name ) of the authentication server. Client/Browser must be able to resolve this FQDN.
Status
This is a known issue logged as BUG0456632 and is fixed in 10.5-50.1 and later versions.
Problem Cause
If a user tries to use a long URL (more than 1024 bytes) to access a protected resource for the first time (that is, without a valid cookie), the NetScaler ADC returns a 500 error.
Issue/Introduction
This article provides a workaround for AAL login that fails through NetScaler with the error "Internal server error 31".
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