Citrix Studio Error: All Services have not been configured

Citrix Studio Error: All Services have not been configured

book

Article ID: CTX139437

calendar_today

Updated On:

Description

Citrix Studio displays the following error:

Error: "All services have not been configured."

Background

When creating a site in Citrix Studio, the following message is generated after entering the license server information and clicking on Connect.

"Error: All services have not been configured."

Error: All services have not been configured

At the message screen, when you click on View error details under Fix it yourself, the following error is displayed: 

View error details

When you scroll to the end, you can notice the following message:

"Inner Exception:

"System.InvalidOperationException. The operation could not be completed as the database has not been configured for the Citrix Configuration Service service."…"

"System.InvalidOperationException

On the previous Database screen, type the Database server location and the Database name, as displayed in the following screen shot: 

 Database server location

After entering the details, when you click Test connection, the following message appears:

“No database was found on the database server.
To create…”

 No database was found on the database server.

After clicking OK, another message appears:

“All database connection tests passed.”

All database connection tests passed.”

The database appears to have been created, but it has not been created, which can be confirmed in SQL, as displayed in the following screen shot:

 The database appears to have been created

You might also get Event ID 18456:

"Login failed for user. Reason: Failed to open the explicity specified database “DatabaseName”

Login failed for user. Reason: Failed to open the explicity specified database “DatabaseName”

Environment

The above mentioned sample code is provided to you as is with no representations, warranties or conditions of any kind. You may use, modify and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that (a) the sample code may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the sample code fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the sample code. In no event should the code be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SAMPLE CODE, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. Although the copyright in the code belongs to Citrix, any distribution of the sample code should include only your own standard copyright attribution, and not that of Citrix. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the sample code.

Resolution

Create a new Virtual Machine from using a sysprep template, then reinstall Citrix Studio.


Problem Cause

Citrix Studio was installed in a cloned Virtual Machine, which has not been sysprepped. This can be verified in the c:\Windows\System32\Sysprep folder, where the Sysprep_succeeded.tag file is missing.

:\Windows\System32\Sysprep

Sysprep_succeeded.tag file

Issue/Introduction

This article provides a resolution to the issue by creating a new Virtual Machine from a sysprepped template and reinstalling Citrix Studio.

Additional Information