Citrix software download link locked or missing

Citrix software download link locked or missing

book

Article ID: CTX139314

calendar_today

Updated On:

Description

  • Link to download not visible
  • Lock displayed under product link
  • Link is grayed out
  • Receiving the following error message when link is selected:
This download is locked
Sorry, the item you are trying to access is restricted and requires additional permissions.  For further assistance, contact Customer Service.

Resolution

Not logged in to My Account 

User must be logged in to My Account prior to attempting to download software.
 

Incorrect web log in

  • Username used to access Downloads from My Account must be associated to account owning product software, (i.e. trying to acquire XenDesktop 7.x software, XenDesktop must be an asset in the account)
  • Verify if the company has multiple accounts and if you have a log in to other accounts, if applicable.


Not eligible for product

Account does not own product/no appropriate license. Purchase product or obtain a Trial license. 


Product is at End of Life

Software is only available for product that hasn’t reached End of Life, check the Product Matrix for verification. 


Subscription Advantage/Customer Success Services expired prior to product release

  • Subscription Advantage (SA) or Customer Success Services (CSS) Expiration date for each license must be equal to or greater than the eligibility date.
  • Submit a renewal or purchase product version for the download. Contact a Citrix Renewal Sales Specialist for further information on renewing Customer Success Services or your trusted Partner for product purchase.


Link is broken

Page won’t open/no product available.  Contact Customer Service via Live Chat and follow the menu's instructions to speak to a Live Agent.


Browser incompatibility

Try another browser.


Firewall interference

Contact your IT department to verify Citrix is not on the blocked list or if the ability to download has been disabled.

 

Having Issues ? 

Contact Customer Service via Live Chat and follow the menu's instructions to speak to a Live Agent.


Problem Cause

Possible causes include:
  • Not logged in to My Account
  • Incorrect web log in
  • Not eligible for product
  • Product is at End of Life
  • Subscription Advantage or CSS expired prior to product release
  • Link is broken  
  • Browser incompatibility
  • Firewall interference
 

Additional Information

CTX111618 | Citrix Product Subscription Advantage Eligibility Dates
CTX126200 | Where to locate and download product software
CTX128597 | How to open a Citrix Customer Service case
CTX126207 | How to retrieve your My Account log in information