Error: "Unable to Create Deployment" on StoreFront

Error: "Unable to Create Deployment" on StoreFront

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Article ID: CTX139042

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Updated On:

Description

The installation of StoreFront fails and the error message “Unable to Create Deployment” is displayed on the console:

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The following are the Event Viewer Errors:

Source:        Citrix Delivery Services Admin
Event ID:      1
Description:   Citrix.DeliveryServices.PowerShell.Command.Runner.Exceptions.PowerShellExecutionException, Citrix.DeliveryServices.PowerShell.Command.Runner, Version=2.3.0.0, Culture=neutral, PublicKeyToken=e8b77d454fa2a856
An error occured running the command: 'Set-DSNewClusterEnvironment'

Source:        Citrix Delivery Services Admin
Event ID:      0
Description:   Exception in deploying server.
Citrix.DeliveryServices.PowerShell.Command.Runner.Exceptions.PowerShellExecutionException: An error occured running the command: 'Set-DSNewClusterEnvironment' ---> System.Management.Automation.ActionPreferenceStopException: Command execution stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: Exception of type 'Citrix.DeliveryServices.Framework.Deployment.Utilities.Exceptions.ServiceOperationTimeOutException' was thrown.

Resolution

To resolve the issue, complete the following steps:
  1. Uninstall StoreFront.

  2. Delete the directory in the path “C:\Program Files\Citrix\Receiver Storefront Directory”.

  3. Install the full profile of .Net Framework 4.0 or 4.5.

  4. Rebuild the performance counters using the KB article - http://support.microsoft.com/kb/2554336.

  5. Reboot the server.

Note: If it still fails to resolve, ensure to add the StoreFront server in the Active Directory domain changing it from Workgroup mode.

Problem Cause

Corrupted performance counters.

Issue/Introduction

This article provides a resolution for the issue occurred during the installation of StoreFront.