Receiver For Windows - Unable to Maximize Published Applications

Receiver For Windows - Unable to Maximize Published Applications

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Article ID: CTX138999

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Updated On:

Description

This article is intended for Citrix administrators and technical teams only. Non-admin users must contact their company’s Help Desk/IT support team and can refer to CTX297149 for more information.

When several published and non-published apps are launched, the minimized published applications cannot be maximized.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Complete the following steps on the client machine with Receiver to resolve the issue and maximize published applications:

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

Note: From CWA for Windows 1912 cu7 ONWARDS and CWA for Windows 2203 onwards there is no need to configure registry in both HKLM and HKCU, either one place is sufficient.

  1. Set the TWITaskbarGroupingMode key to the following value in the path HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\ICA Client\Engine\Lockdown Profiles\All Regions\Lockdown\Virtual Channels\Seamless Windows
    Name: TWITaskbarGroupingMode
    Type: REG_SZ
    Value: GroupNone

  2. Set the TWITaskbarGroupingMode key to the following value in the path HKEY_CURRENT_USER\Software\Citrix\ICA Client\Engine\Lockdown Profiles\All Regions\Lockdown\Virtual Channels\Seamless Windows
    Name: TWITaskbarGroupingMode
    Type: REG_SZ
    Value: GroupNone

  3. Test the application with a seamless application.


Problem Cause

Seamless Taskbar Grouping of hosted, published applications is not set.

Issue/Introduction

This articles provides resolution to published and non published apps launched are unable to be maximized.

Additional Information

CTX138330 - Error: The licenses required by this edition of Citrix Presentation Server are not present on the license server

Citrix Documentation - TWITaskbarGroupingMode