Printers Enter Offline State while Using Citrix Universal Print Server 1.1

Printers Enter Offline State while Using Citrix Universal Print Server 1.1

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Article ID: CTX138855

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Updated On:

Description

During high volume of printing activity, printers that are mapped to a Citrix Universal Print Server 1.1 go offline. Some applications might stop responding when opening a print dialog box.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Notes:

  • This solution is currently available only for Citrix Universal Print Server 1.1.
  • Citrix Universal Print Server 1.1 is only supported for versions 7.x or later..

To resolve this issue, expand the number of threads available to the Citrix XTE Server, which resides on the Print Server. Open the Registry Editor and add the following values:

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

HKLM/SOFTWARE/Wow6432Node/Citrix/XTEConfig
Reg_DWORD MaxThreads
Value =
 a decimal value between 150 and 8,000

Reg_DWORD ThreadLimit
Value =
the value entered for MaxThreads +1

Determine the Number of Threads

Citrix Technical Support is currently investigating ways to determine the number of threads. As a workaround, use the following formula to find the required threads:
  1. Determine an average of how many printers per Citrix Universal Print server are mapped in a user’s ICA session.

  2. Identify the number of users who will be mapping printer to a given Citrix Universal Print Server.

  3. Multiply the values obtained in Step 1 and 2.
    This gives you the number of threads required. Use this value for the MaxThreads value in the httpd.conf file.

  4. For the ThreadLimit value, add 1 to the value used for MaxThreads.


Problem Cause

Certain print dialogs cause UPClient (the client piece of Citrix Universal Print Server) to make excessive connections to the print server. After a certain point, these connections prevent the print server from taking an additional connections and any new printers will appear offline.

To verify this scenario, access the XTE log file on the Citrix Universal Print Server. The log file is located at:

C:\Program Files(x86)\Citrix\XTE\logs\error.log

Inside the log file, check for any or both of the following entries:

  • [Fri Aug 16 15:37:29 2013] [warn] Server ran out of threads to serve requests. Consider raising the ThreadsPerChild setting.
  • [Fri Aug 16 15:40:27 2013] [warn] (OS 64)The specified network name is no longer available. : winnt_accept: Asynchronous AcceptEx failed. GetLastError=64 (The specified network name is no longer available.\r\n).
The first entry is the warning indicating that the Citrix XTE Server is out of worker threads. The second warning with the (OS 64) error is a report of a WinSock error caused by a Client's failed attempt to connect to the service. There might be many of the preceding entries, each entry corresponding to a failed connection attempt.

Note: It is important to understand that both warnings must be present for the symptoms to line up with the cause.

Issue/Introduction

This article provides a resolution when printers enter offline state while using Citrix Universal Print Server 1.1.