Intergy Progress Application Stops Accepting the User Text

Intergy Progress Application Stops Accepting the User Text

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Article ID: CTX138652

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Updated On:

Description

Intergy Progress application stops accepting the text when running seamlessly and using multiple monitors.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

To resolve the issue, complete the following steps:

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.
  1. Add the following seamless flag to the corresponding XenApp server (if multiple XenApp servers are there, add the seamless flag to all XenApp servers hosting Intergy):

    DON’T SEND DISABLE
    Registry Key: HKEY_LOCAL_MACHINE/System/CurrentControlSet/Control/Citrix/wfshell/TWI
    Name: SeamlessFlags
    Type: REG_DWORD
    Data: 8000

  2. Log off from any existing sessions and restart the Intergy application.

Note: The data is a HEX value.

Problem Cause

The Intergy Progress application can intermittently stop accepting the user input because the user is switching between the Intergy application running on one monitor and another application running on a secondary monitor.

This scenario arises when a third party application is used in a multiple monitor setup of the Intergy Progress causing the application to run seamlessly.

Issue/Introduction

This article provides a resolution for the issue in Intergy Progress application that stops accepting the text when running seamlessly and using multiple monitors.

Additional Information

Setting the “DON’T SEND DISABLE” flag reverses the behavior introduced in version 8.0 of the Win32 ICA client for seamless connections of sending the WS_DISABLED Window Style to the client. Supporting this Window Style would cause a small number of custom applications to lose focus to a local application window running on the workstation when the seamless application would set this Window Style and also have an invisible window in the background. The reason for introducing the ability to send the WS_DISABLE window style to the client was to support the implementation of Seamless application windows responding to the “Minimize All” or “Show Desktop” feature on Windows workstations. Therefore, setting this flag has an effect on how seamless windows will respond to the Windows messages sent by using the “Minimize All” or “Show Desktop” feature.

CTX101644 – Seamless Configuration Settings

CTX115146 – FarmTWIHelper - Seamless Configuration Helper Tool