Published Desktops are Unlocked Upon Reconnect

Published Desktops are Unlocked Upon Reconnect

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Article ID: CTX138189

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Updated On:

Description

In XenApp 6, XenApp 6.5, and XenApp 6.5 with Hotfix Rollup Pack 1, with Auto Client Reconnect* enabled, a locked desktop session does not prompt users for credentials after reconnecting.

Both Hotfix Rollup Pack 1 for XenApp 6 and Hotfix Rollup Pack 2 for XenApp 6.5 address this issue.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

The following  are the resolutions for this issue:

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

  • Fix #LA2659 (in Hotfix Rollup Pack 2 for XenApp 6 and Hotfix Rollup Pack 2 for XenApp 6.5) introduces support for the following registry key that allows configuring the session timer:
    HKEY_LOCAL_MACHINE\Software\Wow6432Node\Citrix\WFShell
    Name: SessionReconnectMinTimeInMilliSeconds
    Type: REG_DWORD
    Data: 20000 (default)

  • In addition, Fix #LA3642 (in XA600R02W2K8R2X64020 for XenApp 6 and Hotfix Rollup Pack 2 for XenApp 6.5) allows reverting the behavior introduced by Hotfix Rollup Pack 1 for XenApp 6 and Hotfix Rollup Pack 2 for XenApp 6.5 so that sessions do not prompt users for credentials after reconnecting. To do this, set the following registry key:
    HKEY_LOCAL_MACHINE\Software\Wow6432Node\Citrix\WFShell
    Name: LockOnReconnect
    Type: REG_DWORD
    Data: <0=OFF; any other value=ON (default)>

Caution! Reverting the behavior introduced by Hotfix Rollup Pack 1 for XenApp 6, and Hotfix Rollup Pack 2 for XenApp 6.5 leaves disconnected desktop session unlocked when attempting to reconnect. Doing so might have a security impact in certain deployments.

* This issue affects only the Auto-Client Reconnect feature. It does not affect reconnections using the Session Reliability and Workspace Control features.


Problem Cause

The fix in Hotfix Rollup Pack 1 for XenApp 6 and Hotfix Rollup Pack 2 for XenApp 6.5 that addresses this issue introduces the following new behavior.

The session active time is monitored. If the session active time is less than 20 seconds, the session is locked by default upon reconnection, regardless of the lock status before disconnecting.

Issue/Introduction

This articles addresses the status of a published desktop session lock being kept even after reconnecting post applying the Hotfix Rollup pack on the system.