Error: "An error occurred while making the requested connection" when Starting Apps from Web Interface

Error: "An error occurred while making the requested connection" when Starting Apps from Web Interface

book

Article ID: CTX137958

calendar_today

Updated On:

Description

The error message “An error occurred while making the requested connection” is displayed when starting the applications from Web Interface.

Error message while making the requested connection

This issue might occur temporarily (with up to 30 seconds delay) while adding XenApp servers to the worker groups. Because, the load throttling metric gradually brings up the server without overloading the server with new connections.

Resolution

To remove the load evaluators either recreate or duplicate the application.

Note: By default, the load evaluators are not attached to the applications.


Problem Cause

The load evaluators in the applications cause the issue.

Note: The load evaluators are already available on the XenApp servers.

Issue/Introduction

This article provides the resolution for the error "An error occurred while making the requested connection".

Additional Information

Application Load Evaluators must be used only in a specific situations because the Server Load Evaluators provide the necessary load balancing. There are certain load evaluator metrics that are not applicable to applications. For example, server user load, load throttling and so on. The default and advanced Load Evaluators contain load throttling metric and hence the evaluators must not be attached to the applications. If an Application Load Evaluator needs to be used, use the metric Application User Load. If an Application Load Evaluator and a Server Load Evaluator are used and if any of the metrics from either of load evaluators reaches its threshold (for example CPU usage), the server is unable to accept new connections.

CTX124446 – LBDiag - XenApp Load Balancing Diagnostic Tool

CTX112082 –  Troubleshooting Load Balancing Issues