Error: "A remote application has requested access to a file or information on a device attached to your computer"

Error: "A remote application has requested access to a file or information on a device attached to your computer"

book

Article ID: CTX137759

calendar_today

Updated On:

Description

When a XenApp session is created, the following error message is displayed:

"A remote application has requested access to a file or information on a device attached to your computer."

Resolution

To resolve the error, enable the following policies for every user:

  • USB Devices > Client USB device redirection > Set to prohibited

  • USB Devices > Client USB Plug and Play device redirection > Set to prohibited

Note: This is an expected behavior. You can either allow or restrict the access to the device.


Problem Cause

This error indicates enabled webcam or connected USB device in a machine. In a XenApp session, the client detects the devices and prompts for permission to use the devices.

Issue/Introduction

This article provides a resolution for the error "A remote application has requested access to a file or information on a device attached to your computer".

Additional Information

This issue not only stops the message from appearing, but also disables all USB devices. In XenDesktop or VM hosted applications for XenDesktop, the granular control is higher and specific devices can be disabled. Currently, XenApp does not support this.

Citrix Documentation -  Work with policies.