Multiple Citrix Licenses are Allocated Erroneously for Mobile Laptops

Multiple Citrix Licenses are Allocated Erroneously for Mobile Laptops

book

Article ID: CTX137712

calendar_today

Updated On:

Description

Multiple Citrix licenses can be consumed erroneously for mobile laptops when switching connectivity methods.

Resolution

This behavior is by design.

For a better understanding of license consumption, review and validate the following policy areas for potential licensing impact,

  • Session PreLaunch
  • Session Lingering
  • Session Timeouts
Note: Manually release licenses if multiple licenses are consumed unexpectedly.

Problem Cause

The license allocation request sent from the client XenApp server to the license server contains a different host ID, and therefore another license is consumed. 

For example:

  • When you open a session as UserA from DeviceA using NIC1, one user license is allocated.
  • When you open a session as UserB from DeviceA using NIC1, one device license is allocated.
  • When you open a session as UserB from DeviceA using NIC2, an additional (new) user license is allocated.
Observe that during the Step 3. the NIC1 used on DeviceA is either disabled or disconnected or changed. For example, in a scenario when a laptop transitions from LAN to wireless connectivity the NIC changes.

The licensing device ID algorithm is based on the MAC address of the device running the ICA Client. If a previously used NIC is disabled or disconnected, a new device ID is calculated and used in the license request when the new session is established. An additional user license is consumed because the license server gets a new device ID from the ICA Client.

Issue/Introduction

Multiple Citrix licenses can be consumed erroneously for mobile laptops when switching connectivity methods.

Additional Information

  1. Types of Licenses
  2. CTX132341 - Displaying or Releasing User/Device Licenses on License Server
  3. CTX130943 - Error: No Product Licenses Found on the License Server for the Selected Model
  4. CTX127314 - How to Collect Data for Troubleshooting Licensing Issues
  5. CTX133160 - LSQuery - License Server Data Collection Tool