Importing an Existing vDisk in Provisioning Services Console Causes Error

Importing an Existing vDisk in Provisioning Services Console Causes Error

book

Article ID: CTX137702

calendar_today

Updated On:

Description

When importing a vDisk using the Provisioning Services (PVS) Server Console, the error “Invalid disk file for <vDisk Name>. Cannot add disk” appears.

User-added image

The SoapServer.log displays the following text, if Info level logging is enabled:

INFO  Mapi.Command - Get UndefinedDisks: Disk <vDisk filename> is not valid, needs to be a base .vhd file.

Resolution

Remove the periods (.) from the vDisk filename before importing the vDisk. If there is an existing vDisk Properties file (with the .pvp extension), ensure it matches with the corrected vDisk file names.

Problem Cause

This error can occur if the filename of the vDisk that you are importing has a period (.) anywhere before the .vhd extension.

For example:

  • Test_VDisk.NewVersion.vhd

  • Test_VDisk.1.vhd

Issue/Introduction

When importing a vDisk using the Provisioning Services Server Console “Invalid disk file for . Cannot add disk" is displayed