Error: "Cannot connect to server. Try again in a few minutes" on StoreFront

Error: "Cannot connect to server. Try again in a few minutes" on StoreFront

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Article ID: CTX137519

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Updated On:

Description

End-user is unable to add Store into Receiver, unless the full Store path is appended.

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Example

  • https://SF-FQDN/Citrix/<Store> - Add Store is successful

  • https://SF-FQDN - Add Store fails: After user gets prompted for credentials, an error message appears: "Cannot connect to server. Try again in a few minutes".

Resolution

Complete the following steps to fix the issue:

  1. Replace the old thumb value in the Authentication service Web.Config file with the thumbprint of the new Roaming Certificate: 

    (C:\inetpub\wwwroot\Citrix\Authentication\web.config)

  2. (Recommended) Re-install StoreFront.


Problem Cause

Clicking Generate Security Keys in the StoreFront console's Gateway node creates a new Roaming Delivery Services SSL certificate that is not trusted by the Authentication service. The thumbprint of the SSL certificate is not being updated in the Web.Config file under C:\inetpub\wwwroot\Citrix\Authentication.

Old Roaming Certificate thumbprint

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New Roaming Certificate thumbprint

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Web.Config file used by the Authentication service

You can notice in the following screen shot that it is still using old thumbprint. This must be changed to the thumbprint of the newly created Roaming Certificate.

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Issue/Introduction

Unable to add Store into Receiver after clicking on 'Generate Security Keys' in the StoreFront console.