Unable to Access NetScaler VPX NSIP Associated with AWS EIP

Unable to Access NetScaler VPX NSIP Associated with AWS EIP

book

Article ID: CTX137495

calendar_today

Updated On:

Description

After you create a NetScaler VPX instance and associate an Elastic IP (EIP) address with this instance, occasionally you cannot access the NetScaler IP (NSIP) address from the Internet.

Resolution

To resolve this issue, complete the following procedure:

  1. To inspect and change the security setting on NetScaler VPX instance, open AWS EC2 console.

  2. Click the instance.

    User-added image

  3. Ensure that port 22, 80, or 443 (whichever you are trying to access) is listed.

  4. If either of the port you are trying to access is not listed, proceed to the next step to modify the Security Group at VPC level.

  5. In the AWS console, select VPC.

  6. Select the Security Groups in the Security tab.

    User-added image
  7. Select the Security Group and then click Inbound or Outbound.

  8. Ensure that the appropriate ports are open.

    User-added image

This issue might also occur if EIP is not associated with the NSIP address.

To attach EIP to NSIP address, complete the following procedure:

  1. Log on to AWS console EC2 environment.

  2. Click Elastic IP tab in the NETWORK & SECURITY section.

  3. Click Allocate New Address.

  4. Select VPC as EIP used.

  5. Click Yes > Allocate.

  6. Right-click the new IP address.

  7. Select Associate.

  8. Associate with NetScaler instance.

Note: Here you are associating the new IP address with the secondary appliance NSIP.


Problem Cause

NSIP (EIP) access is denied by the Virtual Private Cloud (VPC) environment because the security setting available when creating the NetScaler VPX instance might not be allowed for port 22, 80, or 443 access.

Issue/Introduction

After you create a NetScaler VPX instance and associate an Elastic IP address with this instance, occasinally you cannot access the NetScaler IP address from the Internet.