Published Microsoft RDP Client when Used to Connect to Another Server or Workstation does not carry through XenApp Local Client Drives

Published Microsoft RDP Client when Used to Connect to Another Server or Workstation does not carry through XenApp Local Client Drives

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Article ID: CTX137342

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Updated On:

Description

A published Microsoft RDP client when used to connect to another Server or Workstation does not carry through XenApp local client drives.

Resolution

Ensure that the server or workstation the RDP client is trying to connect has client drive mapping enabled directly on the RDP-TCP port or through a Microsoft Policy. For example if you are using the RDP client to connect to a Windows 2008 R2 server check the following:

  1. Goto the Admin tool > Remote Desktop Session Host Configuration utility.

  2. In the Properties of the RDP-TCP port, select Client Settings tab.

  3. In the Redirection tab, ensure the Drive checkbox is unchecked. If this check box is checked, it will disable drive mapping for RDP.

    Note: If these settings are grayed out and not configurable, then Microsoft GPO might be enabled (see Microsoft policy location) or permissions to change this is not available. If this is the case, ensure to login as an administrator.

The Microsoft policy is located at Computer > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Device and Resource Redirection.

Ensure that the policy is NOT Enabled and NOT set to Do not allow drive redirection.


Problem Cause

XenApp is only responsible for mapping the local client drives of the user when the published RDP client is launched. When the published RDP client is used to connect to another Server or Workstation, it depends on the Microsoft RDP protocol to carry the local client drives of the user to the server or workstation it is connecting.

Issue/Introduction

A published Microsoft RDP Client when used to connect to another server or workstation does not carry through XenApp local client drives.

Additional Information

This is an expected behavior.

The simplest method to ensure XenApp is mapping local client drives for the RDP protocol to carry through on its connection is:
Open the published Microsoft RDP client without connecting to any device, open the client, and then open a second published application to session share, like notepad.

When the published notepad is opened and you verify that it is sharing the same session as the published RDP, then in Notepad > File > Open, you must see the clients local drives to check for XenApp. Now it is up to Microsoft RDP protocol to carry the drives through when you use it to make a connection.

Additionaly, a simple test to ensure RDP is allowing local drive redirection is to use the RDP client and connect directly to the server you are trying to connect to with the published RDP.  If the drives fail to map again, this is a configuration issue on the Microsoft end and if this solution does not help to resolve the issue, contact Microsoft directly.

CTX238200 - How to Troubleshoot Client Drive Mapping

Device and Resource Redirection