PVS SOAP Service Crashes After Running the Auto Update

PVS SOAP Service Crashes After Running the Auto Update

book

Article ID: CTX137309

calendar_today

Updated On:

Description

Provisioning Services Simple Object Access Protocol service crashes after running the Auto Update. The Auto Update feature in Provisioning Services (PVS) allows a master target to receive an update and roll it out to the target devices. The completion is signaled to the Windows Application log by an event.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

Complete the following steps to fix the issue:
  1. Add the following registry entry in all the PVS servers in the site:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\eventlog\Application\Citrix Vdisk Update Service

  1. Add a new key called EventMessageFile of type REG_EXPAND_SZ under the preceding entry.

  2. Add the following text with its value as either 32-bit or 64-bit versions: 

    • 32-bit - %windir%\Microsoft.NET\Framework\v2.0.50727\EventLogMessages.dll
    • 64-bit - %windir%\Microsoft.NET\Framework64\v2.0.50727\EventLogMessages.dll

Problem Cause

In PVS 6.1 releases, Windows Log subsystem of the target device generates an error in the SOAP service because the user is not having proper permissions to generate the log messages. A security violation is returned from a Windows call and crashing the Simple Object Access Protocol (SOAP) service. 

Issue/Introduction

This article provides a resolution when PVS SOAP Service crashes after running the auto update.