Error 1603 Occurs When Installing Hotfix Rollup Pack 2 on XenApp 6.0

Error 1603 Occurs When Installing Hotfix Rollup Pack 2 on XenApp 6.0

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Article ID: CTX136996

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Updated On:

Description

Error 1603 occurs when installing Hotfix Rollup Pack2 on XenApp 6.0.

Troubleshooting Methodology

The Technical Support Engineer completed the following steps to resolve the issue:

  • Enabled msi logging and attempted the hotfix rollup pack install again. Error 1603 occurred.

  • Examined the msi logs; the following was observed:

    CtxSetUserRights: SetAccountRights('ctx_cpuuser', 'SeDebugPrivilege') failed (1788)
    CtxSetUserRights: SetAccountRights('ctx_cpuuser', 'SeIncreaseBasePriorityPrivilege') failed (1788)

After examining the local user accounts on the server, it was found that there was no ctx_cpuuser account on the local machine.

Resolution

To resolve the issue, create a local account named ctx_cpuuser. The Hotfix Rollup Pack will be installed successfully.


Problem Cause

This error occurs because the installation is attempting to modify the rights on the ctx_cpuuser account. As the account does not exist, the installation failed.

Issue/Introduction

This article contains information on how to troubleshoot Error 1603 that occurs while installing Hotfix Rollup Pack 2 on XenApp 6.0.

Additional Information

Instructions for Turning on msi Logging
XenApp administrators