Error: "Invalid disk file for [vDisk name]. Cannot add disk" when Importing vDisk

Error: "Invalid disk file for [vDisk name]. Cannot add disk" when Importing vDisk

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Article ID: CTX136757

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Updated On:

Description

When importing vDisk, the following error appears:
“Invalid disk file for [vDisk name]. Cannot add disk”
User-added image

After clicking OK, the following error appears:
“The scan did not find any new vDisks”
User-added image

Resolution

Rename the .vhd file in the vDisk store and import the vDisk using the Add or Import Existing vDisks. This process cannot be done if vDisk versions exist.
Note: vDisk with the same name cannot be imported in the same Provisioning Service farm.


Problem Cause

While copying and importing the .vhd file to be used in another Provisioning Service vDisk store, the original file cannot be imported using the Add or Import Existing vDisks option. The .vhd file name must be renamed to be imported successfully.
Another probable cause is a corrupted .pvp file, in which case it should be recreated.

Issue/Introduction

This article provides resolution to the error "Invalid disk file for [vDisk name]. Cannot add disk” that appears when importing vDisk.

Additional Information

Citrix eDocs - Exporting and Importing vDisks