Performance Issues with Surge Protected Load Balancing Server on NetScaler

Performance Issues with Surge Protected Load Balancing Server on NetScaler

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Article ID: CTX136420

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Description

An SSL load balancing virtual server on the NetScaler appliance experiences load balancing performance issues. Users are experiencing long response times or time outs when accessing Outlook Web Access (OWA), load balanced by the NetScaler appliance.

The SSL load balancing virtual server is load balancing two SSL OWA servers. During peak hours, the OWA logon page could take more than a minute to load or eventually time out. Failing over to the secondary appliance cleared up the problem, but then performance issues reoccur.

Resolution

You must add more back end servers to the service group to handle the increased traffic.

  1. Perform stress tests to see how many more back end servers you have to add to the Service Group.

  2. Throttle the Surge Protection features as needed. For more information refer to Citrix Documentation - Surge Protection.


Problem Cause

The NetScaler logs indicate that the Surge Queue is building up, which is the reason for the performance issues. The NetScaler appliance is preventing the back end servers from overloading, by placing the requests in a Surge Queue, until connections free up. The Surge Queue increased to the point where users experienced long response times or eventually timing the connection out.

Issue/Introduction

This article has information on how to troubleshoot load balancing performance issues with Surge Protection on NetScaler.

Additional Information

CTX113341 - How to Obtain Performance Statistics and Event Logs from a NetScaler