Citrix User Profile Data Not Exported Back to Citrix Profile Management User Store
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Article ID: CTX135452
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Updated On:
Description
When user logs off, the profile data of the user are not being exported back to the Citrix Profile Management (CPM) store. Only the UPMSettings.ini is being copied.
Resolution
Customize the
Windows default profile folder appropriately according to
Microsoft recommendation as outlined in
973289. This ensures proper permission/access is set for the default user profile to be used by other users.
Problem Cause
This is caused by misconfiguration of the default profile customization performed on the Windows machine where it was actually replaced by another user's Windows profile on the machine CPM is installed. This was done as part of Windows default user profile customization and CPM profile migrated from a user that has created the Windows local profile from this customized default user profile.
In the CPM log, you can see the following error logged:
ERROR;PARTNERS;pja1;3;11544;RecurseRegistry: Opening the key <S-1-5-21-8915387-943144406-
1916815836-1468_tmp\Software\Microsoft\SystemCertificates\Root\ProtectedRoots> failed with: Access is denied.
;ERROR;PARTNERS;pja1;3;11544;CRegistryHive::ResetSecurity: Failed to reset security on registry hive
<C:\Users\pja1\NTUSER.DAT>. ERROR;CreateLocalProfileFromTemplate: Could not create a local profile from a
template: Access is denied. ProcessLogon: SetupLocalProfile failed
Issue/Introduction
This article conatins information on user's profile data not being exported back to the Citrix Profile Management (CPM) store when the user logs off and only the UPMSettings.ini is being copied.
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