Receiver Launching Seamless Application Displays Legal Message even after Clicking OK

Receiver Launching Seamless Application Displays Legal Message even after Clicking OK

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Article ID: CTX135413

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Updated On:

Description

When using Receiver to launch a Seamless Application on a server, which has a legal notice set up to be displayed to user, prior to application launch, user has to click OK to proceed to launching Application. When user clicks OK, the application is unresponsive and the screen containing legal message appears to lose focus. User must click OK multiple times in quick succession for application to launch.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

To ensure seamless application launch, set the following registry setting on the client system.

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

HKEY_LOCAL_MACHINE\Software\Citrix\ICA Client\Engine\Configuration\Advanced\Modules\WFClient

Create a string value, REG_SZ, called TWISeamlessFlag with a value data of 1.

For 64-bit Windows the REGEDIT key must be created at the following location: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\ICA Client\Engine\Configuration\Advanced\Modules\WFClient

Problem Cause

When launching the seamless application, if another process requests a foreground focus then this focus is not returned to the seamless window.

Issue/Introduction

This article provides resolution to ensure seamless application launch in the foreground has focus even if focus is requested by another process or shifted away from logon dialog.

Additional Information

CTX101644 - Seamless Configuration Settings