Configured Policies Do Not Apply to XenApp Worker Groups

Configured Policies Do Not Apply to XenApp Worker Groups

book

Article ID: CTX135148

calendar_today

Updated On:

Description

This issue occurs if the computer policies from the Delivery Service Console are configured correctly but are not applied correctly on the Worker Groups.

The policies are reviewed from the console and it is configured correctly.

User-added image


Policy settings are stored in the following locations:

  • 32-bit component Registry location
    HKLM\Software\Policies\Citrix
  • 64-bit component Registry location
    HKLM\Software\Wow6432Node\Policies\Citrix
The registry key Evidence\ServerGroup contains the names of the Worker Groups to which the policies apply.

User-added image

Resolution

Complete one of the following appropriate resolutions to resolve the issue:

If Worker Group is renamed

Delete the Worker Group and create a new one.

If Worker Group name is entered incorrectly

Check that the name on the registry key Evidence\ServerGroup is the same that is applied policies.

Note: The Worker Group name is case-sensitive. The white space, if any, in the name must be entered exactly the same way while configuring policy.

User-added image

Problem Cause

This issue may occur if:
  1. The Worker Group is renamed and the name is not updated in the registry key Evidence\ServerGroup.

  1. The name of the Worker Group is entered incorrectly when configuring the policy.

User-added image

    Issue/Introduction

    This article provides resolution to configure policies when they do not apply to XenApp Worker Groups.