Error “Your request to connect to this Citrix server has been rejected due to insufficient buffers. Please call your system administrator. Click OK to terminate.”

Error “Your request to connect to this Citrix server has been rejected due to insufficient buffers. Please call your system administrator. Click OK to terminate.”

book

Article ID: CTX134911

calendar_today

Updated On:

Description

A published application fails to launch and the following error is displayed:

“Your request to connect to this Citrix server has been rejected due to insufficient buffers. Please call your system administrator. Click OK to terminate.”

User-added image

Resolution

Complete the following to resolve this issue:
  1. If using Windows clients, use the LongCommandLine setting.  Refer to ICA Settings Reference.

  1. Application can be launched using a script as a workaround. Refer to CTX966450 - How to Publish an Application Using a Shortcut (.lnk file) for more information.


    Problem Cause

    The length of the command line used to launch the published application (InitialProgram) exceeded 256 characters including the path to icast.exeand the ending null character.
    The 256 character limitation is defined by a Microsoft constant on the terminal server.

    Issue/Introduction

    This article provides resolution to the error “Your request to connect to this Citrix server has been rejected due to insufficient buffers. Please call your system administrator. Click OK to terminate.”