Application Fails To Launch on a XenApp Server 2008 R2 with Profile Unity 4.7 Installed

Application Fails To Launch on a XenApp Server 2008 R2 with Profile Unity 4.7 Installed

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Article ID: CTX134736

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Updated On:

Description

Application fails to launch on a XenApp Server 2008 R2 with Profile Unity 4.7 being installed. Launching a published application causes the application to fail to launch displaying the following error:
“The Citrix server is unable to process your request to start this published application at this time.”
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Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

Change the registry setting that had been altered by the Profile Unity application back to the original path to the systems userinit.exe
The registry key location is: HKLM\Software\Microsoft\WindowsNT\Winlogon\userinit. Change the path back to C:\windows\system32\userinit.exe.
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Problem Cause

Profile Unity is a profile management solution for virtual desktop deployments and physical PCs. Profile Unity decouples user profiles and data from the operating system for migration to VMware View, Citrix XenDesktop, or any platform that supports Windows OS.

Version 4.7 uses a proprietary userinit.exe that changes the registry key and modifies the original path to the operating systems userinit.exe causing applications to fail to launch. The traditional userinit.exe file can be seen from a Process Monitor trace on a XenApp server with no Profile Unity installed.
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If Profile Unity is installed, the icon is different (refer following screen shot), and the provider states Liquid Labs Inc.
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Since Profile Unity has changed the traditional userinit.exe, the process does not read the location in the registry for the AppSetup key causing core processes to not start like Cmstart.exe, CtxHide.exe, and UsrLogon.cmd.
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If Cmstart.exe does not run, then wfshell.exe also does not run. And when wfshell.exe does not run, the icast.exe process will not launch the application, and disconnects the session.
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Issue/Introduction

This article contains instructions to launch applications successfully on a XenApp Server 2008 R2 with Profile Unity 4.7 installed.