Shadow Failed. Error Code 120

Shadow Failed. Error Code 120

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Article ID: CTX134090

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Updated On:

Description

Shadow Failed. Error Code 120.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

Complete the following steps to resolve the error:
  1. On the non-working server open reg key: HKLM\Software\Wow6432Node\Citrix\Install.

  2. Look for a Binary entry called Setting.

Note: If this entry is not present, shadowing will not work.

  1. On a working server, open reg key: HKLM\Software\Wow6432Node\Citrix\Install.

  2. Look for a Binary entry called Setting, as shown in the screen shot:

User-added image
 
  1. Note the binary number on the working server and on the non-working server; create the binary entry called Setting at: HKLM\Software\Wow6432Node\Citrix\Install.

  2. Enter the number from the working server in the non-working server.


Problem Cause

Typically this would be caused by the user having multi-monitors

Issue/Introduction

The reg key removal by some device, user or removal of the farm causes an error 120 to be presented on a server.

Additional Information

CTX125693 - Error: Shadow failed. Error Code 7044 and 120
CTX126894 - A Multi-Monitor Published Desktop Session on XenApp Appears as Single Monitor Session