Citrix XTE Server Fails to Start

Citrix XTE Server Fails to Start

book

Article ID: CTX133950

calendar_today

Updated On:

Description

Provisioned XenApp servers fail to start Citrix XTE Servers randomly. Reboot of about 500-600 XenApp servers are performed and found five to ten servers with this behavior every day.

The following error message is observed:

User-added image

At server Event Viewer, the following message is displayed:

User-added image

On the HTTPD.CONF file located at Program Files (x86)\Citrix\XTE\conf folder, the following entry specific to the module is displayed:

LoadModule winevent_log_module modules/mod_winevent_log.so

Resolution

Workaround

As a workaround, complete the following steps:

  1. Comment the following line at Program Files (x86)\Citrix\XTE\conf\httpd.conf file: 
    #LoadModule winevent_log_module modules/mod_winevent_log.so.

  2. Change httpd.conf file attributes as Read Only. This ensures IMA Service does not rewrite httpd.conf file depending on NIC association with ICA Listener.

  3. Start Citrix XTE Server.


Problem Cause

This behavior is caused when Common Gateway Protocol (CGP) is not enabled at XenApp Server and cannot start up Citrix XTE Server. However, users connect using ICA 1494 automatically when port 2598 for CGP cannot be reached.

Issue/Introduction

Provisioned XenApp servers fail to start Citrix XTE Servers randomly. Reboot of about 500-600 XenApp servers done and found five to ten servers with this behavior every day.

Additional Information

For further troubleshooting and analysis, contact Citrix Technical Support.