Error: "Cannot verify database connectivity" on StoreFront

Error: "Cannot verify database connectivity" on StoreFront

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Article ID: CTX133734

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Updated On:

Description

Though StoreFront server is able to communicate to the SQL server over TCP port 1433, when you click Test Connection at the Deploy Multiple Server Group setup Window for StoreFront 1.1, the connection fails with the following message:

Cannot verify database connectivity. The connection string generated from the database name and server cannot be verified.
Check the database information or update the connection string and try again."

Citrix Receiver Storefront

Event viewer message in Windows Logs\Applications on SQL server shows the following message:

Event ID 18456 from source MSSQLSERVER:
"Login failed for user ‘domain\user’, Reason: Token-based server access validation failed with an infrastructure error. Check for previous errors. [CLIENT: <IP of StoreFront server>]”

Citrix Receiver Storefront

Resolution

Use the same administrator account to run the Deploy Multiple Server Group configuration that was used to create the StoreFront SQL database.


Problem Cause

This is an issue with permissions caused when a different administrator run the Deploy Multiple Server Group configuration, compared to what was used to create the StoreFront SQL database.

Issue/Introduction

This article describes about the error: "Cannot verify database connectivity. The connection string generated from the database name and server cannot be verified. Check the database information or update the connection string and try again".