Fixing Duplicate User Profile Folders Created at Session Logon

Fixing Duplicate User Profile Folders Created at Session Logon

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Article ID: CTX133624

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Description

When using User Profile Management (UPM), sometimes 2 (two) user profile folders are created at logon. These user profile folders are used simultaneously during the session. This article explains how to fix this issue.

Background

When a user logs on a computer managed by UPM, duplicate user profile folders Username and Username.domain are created in Documents and Settings folder. These two folders are created at the same time (see screen shot). They are locked and used by the operating system simultaneously.

User-added image

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

In order to fix these values, you must either recreate the damaged profiles or reset the wrong User Shell Folders paths. This can be performed:

  • Manually

  • By applying a custom Group Policy which resets User Shell Folders

  • Using a script that modifies the registry keys values

Or alternatively by using this Microsoft Fix-It tool: http://support.microsoft.com/kb/886549.


Problem Cause

This issue can be caused by misconfigured User Shell Folders values in Windows Registry Database. Under HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders, every user shell folder path has to use %USERPROFILE% environment variable instead of “C:\Documents and settings\USERNAME”.

Issue/Introduction

This article contains information to fix duplicate User Profile folders created at Session Logon.