Error - "Failed to initiate Remote Assistance: Another Remote Assistance session is in progress (error code 105) when attempting to shadow"

Error - "Failed to initiate Remote Assistance: Another Remote Assistance session is in progress (error code 105) when attempting to shadow"

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Article ID: CTX133510

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Updated On:

Description

When trying to shadow using Desktop Director, the following error message is displayed:
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Resolution

The browser downloads a Microsoft Remote Assistance (.msra) file which must be opened with the Remote Assistance client to start a shadowing session.
To allow Internet Explorer to start Remote Assistance automatically, enable the Internet Explorer Downloads > Automatic prompting for file downloads security setting. By default, this option is enabled for sites in the Local intranet zone. If the Desktop Director site is not in the Local intranet zone, add the site manually to this zone.
See Microsoft KB - How to configure Internet Explorer to automatic download prompts on your Windows XP Service Pack 2-based computer.


Problem Cause

This happens because when the shadow starts, Internet Explorer blocks the site from downloading.
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When the user clicks on shadow, a request is sent to the Virtual Machine, which waits for about 2-3 minutes for a response. If Internet Explorer blocks the download, the Virtual Machine still thinks that it is waiting for the initial connection and sees the second try as a new connection.

Issue/Introduction

This article provides resolution to Error - "Failed to initiate Remote Assistance: Another Remote Assistance session is in progress (error code 105) when attempting to shadow".